# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^#]*#([^#]*)#[^#]*#\1.*$"
test_str = ("someString#MY_STRING#someString#MY_STRING#someString#\n"
"someString#MY_STRING#someString#MY_TRING#someString#")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.