const regex = /^[^#]*#([^#]*)#[^#]*#\1.*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^#]*#([^#]*)#[^#]*#\\1.*$', 'gim')
const str = `someString#MY_STRING#someString#MY_STRING#someString#
someString#MY_STRING#someString#MY_TRING#someString#`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);