use strict;
my $str = 'asdsadas://
//
213123dasdsad://';
my $regex = qr/^(?:[a-z]+:)?\/\//imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";