import re
regex = re.compile(r"[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("nissan\n"
"Company name nissan and Nissan Micra product.\n"
"<p>Company name nissan and Nissan Micra product.</p>\n\n\n"
"You know Nissan become now http://www.nissan.com. \n"
"<p>www.nissan.com </p>\n"
"<p>Now nissan become now www.nissan.com</p>\n"
"<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")