# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s+/>/gm;t' <<< "
<p> text 1 </p>
<p> text 2 </p>
<p> text 3 </p>
<p> text 4 </p>"