use strict;
my $str = '
<p> text 1 </p>
<p> text 2 </p>
<p> text 3 </p>
<p> text 4 </p>';
my $regex = qr/^\s+/mp;
my $subst = '>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";