import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+";
final String string = " \n"
+ " <p> text 1 </p>\n"
+ " <p> text 2 </p>\n"
+ " <p> text 3 </p>\n"
+ " <p> text 4 </p>";
final String subst = ">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}