#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s+"
Local $sString = " " & @CRLF & _
" <p> text 1 </p>" & @CRLF & _
" <p> text 2 </p>" & @CRLF & _
" <p> text 3 </p>" & @CRLF & _
" <p> text 4 </p>"
Local $sSubst = ">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)