package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+`)
var str = `
<p> text 1 </p>
<p> text 2 </p>
<p> text 3 </p>
<p> text 4 </p>`
var substitution = ">"
fmt.Println(re.ReplaceAllString(str, substitution))
}