$re = '/^\s+/m';
$str = '
<p> text 1 </p>
<p> text 2 </p>
<p> text 3 </p>
<p> text 4 </p>';
$subst = ">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;