import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s.*href\\s?=\\s?[\"'](\\bmailto:\\b|\\bhttp:\\/\\/\\b|\\bhttps:\\/\\/\\b).*[\"'].*?>.*?<\\/a>";
final String string = "<a style=\"\" href=\"https://www.dr.dk'>click here</a>\n"
+ "<a style=\"\" href=\"http://www.dr.dk'>click here</a>\n"
+ "<a href = \"http://www.dr.dk'>click here</a>\n"
+ "<ahref=\"https://www.dr.dk'>click here</a> Error in tag\n"
+ "<a href = https://www.dr.dk>click here</a> No quote marks\n"
+ "<a href=\"https://www.dr.dk\"> c l i c k h e r e </a>\n"
+ "<a href=\"mailto:ghf\">mail</a>\n"
+ "<a href=\"https://www.dr.dk\" class=\"link\"> c l i c k h e r e </a>\n"
+ "<a href =\"https://www.dr.dk\" class=\"link\"> c l i c k h e r e </a>\n"
+ "<A HREF = \"http://\">hej</a> <-No link\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}