# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a\s.*href\s?=\s?[\"'](\bmailto:\b|\bhttp:\/\/\b|\bhttps:\/\/\b).*[\"'].*?>.*?<\/a>"
test_str = ("<a style=\"\" href=\"https://www.dr.dk'>click here</a>\n"
"<a style=\"\" href=\"http://www.dr.dk'>click here</a>\n"
"<a href = \"http://www.dr.dk'>click here</a>\n"
"<ahref=\"https://www.dr.dk'>click here</a> Error in tag\n"
"<a href = https://www.dr.dk>click here</a> No quote marks\n"
"<a href=\"https://www.dr.dk\"> c l i c k h e r e </a>\n"
"<a href=\"mailto:ghf\">mail</a>\n"
"<a href=\"https://www.dr.dk\" class=\"link\"> c l i c k h e r e </a>\n"
"<a href =\"https://www.dr.dk\" class=\"link\"> c l i c k h e r e </a>\n"
"<A HREF = \"http://\">hej</a> <-No link\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.