import Foundation
let pattern = #"<a\s.*href\s?=\s?["'](\bmailto:\b|\bhttp:\/\/\b|\bhttps:\/\/\b).*["'].*?>.*?<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<a style="" href="https://www.dr.dk'>click here</a>
<a style="" href="http://www.dr.dk'>click here</a>
<a href = "http://www.dr.dk'>click here</a>
<ahref="https://www.dr.dk'>click here</a> Error in tag
<a href = https://www.dr.dk>click here</a> No quote marks
<a href="https://www.dr.dk"> c l i c k h e r e </a>
<a href="mailto:ghf">mail</a>
<a href="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<a href ="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<A HREF = "http://">hej</a> <-No link
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)