const regex = /<a\s.*href\s?=\s?["'](\bmailto:\b|\bhttp:\/\/\b|\bhttps:\/\/\b).*["'].*?>.*?<\/a>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s.*href\\s?=\\s?["\'](\\bmailto:\\b|\\bhttp:\\\/\\\/\\b|\\bhttps:\\\/\\\/\\b).*["\'].*?>.*?<\\\/a>', 'gi')
const str = `<a style="" href="https://www.dr.dk'>click here</a>
<a style="" href="http://www.dr.dk'>click here</a>
<a href = "http://www.dr.dk'>click here</a>
<ahref="https://www.dr.dk'>click here</a> Error in tag
<a href = https://www.dr.dk>click here</a> No quote marks
<a href="https://www.dr.dk"> c l i c k h e r e </a>
<a href="mailto:ghf">mail</a>
<a href="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<a href ="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<A HREF = "http://">hej</a> <-No link
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}