use strict;
my $str = '<a style="" href="https://www.dr.dk\'>click here</a>
<a style="" href="http://www.dr.dk\'>click here</a>
<a href = "http://www.dr.dk\'>click here</a>
<ahref="https://www.dr.dk\'>click here</a> Error in tag
<a href = https://www.dr.dk>click here</a> No quote marks
<a href="https://www.dr.dk"> c l i c k h e r e </a>
<a href="mailto:ghf">mail</a>
<a href="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<a href ="https://www.dr.dk" class="link"> c l i c k h e r e </a>
<A HREF = "http://">hej</a> <-No link
';
my $regex = qr/<a\s.*href\s?=\s?["'](\bmailto:\b|\bhttp:\/\/\b|\bhttps:\/\/\b).*["'].*?>.*?<\/a>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}