#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$"
Local $sString = "3-728-2208" & @CRLF & _
"1-728-2208" & @CRLF & _
"22PI-55555-666666" & @CRLF & _
"PE-333-333" & @CRLF & _
"PÉ-1-4444" & @CRLF & _
"N-4444-55555" & @CRLF & _
"Ñ-22-22" & @CRLF & _
"E-1-1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")