$re = '/^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$/m';
$str = '3-728-2208
1-728-2208
22PI-55555-666666
PE-333-333
PÉ-1-4444
N-4444-55555
Ñ-22-22
E-1-1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);