// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$").unwrap();
let string = "3-728-2208
1-728-2208
22PI-55555-666666
PE-333-333
PÉ-1-4444
N-4444-55555
Ñ-22-22
E-1-1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}