const regex = /^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,2}(?:PI)?|P?E|N)-\\d{1,5}-\\d{1,6}$', 'gm')
const str = `3-728-2208
1-728-2208
22PI-55555-666666
PE-333-333
PÉ-1-4444
N-4444-55555
Ñ-22-22
E-1-1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}