using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$";
string input = @"3-728-2208
1-728-2208
22PI-55555-666666
PE-333-333
PÉ-1-4444
N-4444-55555
Ñ-22-22
E-1-1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}