use strict;
my $str = '3-728-2208
1-728-2208
22PI-55555-666666
PE-333-333
PÉ-1-4444
N-4444-55555
Ñ-22-22
E-1-1
';
my $regex = qr/^(?:\d{1,2}(?:PI)?|P?E|N)-\d{1,5}-\d{1,6}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}