using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)";
string substitution = @"";
string input = @"_@##%Default__$*_123_";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}