$re = '/(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)/m';
$str = '_@##%Default__$*_123_';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;