re = /(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)/m
str = '_@##%Default__$*_123_'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result