const regex = /(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)', 'gm')
const str = `_@##%Default__\$*_123_`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);