# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF/$1/gm;t' <<< "#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
"