// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF").unwrap();
let string = "#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}