package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF`)
var str = `#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}