#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF"
Local $sString = "#IF false" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
"#IF true" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
"#IF false" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
"#IF true" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)