use strict;
my $str = '#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
';
my $regex = qr/(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";