# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)#IF\s*false.*?#ENDIF|#IF\s*true\R(.+?)\R#ENDIF"
test_str = ("#IF false\n"
"If true the text should remain, else it should be deleted\n"
"#ENDIF\n"
"#IF true\n"
"If true the text should remain, else it should be deleted\n"
"#ENDIF\n"
"#IF false\n"
"If true the text should remain, else it should be deleted\n"
"#ENDIF\n"
"#IF true\n"
"If true the text should remain, else it should be deleted\n"
"#ENDIF\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.