// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Koord\.\sWGS-[EW]\s:\s(\d+\.\d+)[\r\n]Koord\.\sWGS-[NS]\s:\s(\d+\.\d+)").unwrap();
let string = "Koord. WGS-E : 9.8247876439
Koord. WGS-N : 49.5694479485
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}