#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(<div class="hello">){1}(.)*(<\/div>){1}"
Local $sString = "<div class="hello">" & @CRLF & _
"" & @CRLF & _
"<span>Hello World<span>" & @CRLF & _
"" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")