using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div class=""hello"">){1}(.)*(<\/div>){1}";
string input = @"<div class=""hello"">
<span>Hello World<span>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}