re = /(<div class="hello">){1}(.)*(<\/div>){1}/i
str = '<div class="hello">
<span>Hello World<span>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end