const regex = /(<div class="hello">){1}(.)*(<\/div>){1}/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<div class="hello">){1}(.)*(<\\\/div>){1}', 'is')
const str = `<div class="hello">
<span>Hello World<span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}