import re
regex = re.compile(r"(<div class=\"hello\">){1}(.)*(<\/div>){1}", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<div class=\"hello\">\n\n"
"<span>Hello World<span>\n\n"
"</div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")