$re = '/(<div class="hello">){1}(.)*(<\/div>){1}/is';
$str = '<div class="hello">
<span>Hello World<span>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);