using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(cat|test).*$";
string input = @"https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
https://site.ru/test
https://site.ru/tsadasdas
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}