const regex = /^.*(cat|test).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(cat|test).*$', 'gm')
const str = `https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
https://site.ru/test
https://site.ru/tsadasdas
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}