package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(cat|test).*$`)
var str = `https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
https://site.ru/test
https://site.ru/tsadasdas
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}