import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(cat|test).*$";
final String string = "https://site.ru/?a=1\n"
+ "https://site.ru/cat1.html\n"
+ "https://site.ru/cat1/\n"
+ "https://site.ru/test\n"
+ "https://site.ru/test\n"
+ "https://site.ru/tsadasdas\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}