// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(cat|test).*$").unwrap();
let string = "https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
https://site.ru/test
https://site.ru/tsadasdas
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}