#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0|[1-9][0-9]*)$"
Local $sString = "xdzbcqhbucbsd" & @CRLF & _
"8148419984" & @CRLF & _
"86164849484914" & @CRLF & _
"61814671" & @CRLF & _
"-49848489" & @CRLF & _
"844848484" & @CRLF & _
"8484818478484845484818454754848484848484848484548485184849848984984" & @CRLF & _
"8484848484884848984848" & @CRLF & _
"9848498498498498499848" & @CRLF & _
"40800" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")