package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0|[1-9][0-9]*)$`)
var str = `xdzbcqhbucbsd
8148419984
86164849484914
61814671
-49848489
844848484
8484818478484845484818454754848484848484848484548485184849848984984
8484848484884848984848
9848498498498498499848
40800
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}