use strict;
my $str = 'xdzbcqhbucbsd
8148419984
86164849484914
61814671
-49848489
844848484
8484818478484845484818454754848484848484848484548485184849848984984
8484848484884848984848
9848498498498498499848
40800
0';
my $regex = qr/^(0|[1-9][0-9]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}