// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0|[1-9][0-9]*)$").unwrap();
let string = "xdzbcqhbucbsd
8148419984
86164849484914
61814671
-49848489
844848484
8484818478484845484818454754848484848484848484548485184849848984984
8484848484884848984848
9848498498498498499848
40800
0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}