import re
regex = re.compile(r"^(0|[1-9][0-9]*)$", flags=re.MULTILINE)
test_str = ("xdzbcqhbucbsd\n"
"8148419984\n"
"86164849484914\n"
"61814671\n"
"-49848489\n"
"844848484\n"
"8484818478484845484818454754848484848484848484548485184849848984984\n"
"8484848484884848984848\n"
"9848498498498498499848\n"
"40800\n"
"0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")