use strict;
my $str = 'Valid emails:
user@domain.ru
na_me.lastname@subdomain.domain.ru
name-lastname@7.sub-sub-domain.subdomain.domain.ru
ni+ck\'name-name.lastname@d.oma-in-domain.ru
Invalid addresses in the user section:
.user@domain.ru
user.@domain.ru
-user@domain.ru
user-@domain.ru
us..er@domain.ru
us--er@domain.ru
Invalid addresses in the domain section:
user@-domain.ru
user@.subdomain.domain.ru
user@subdomain-.domain.ru
user@subdomain..domain.ru
user@domain.-domain.ru
user@dom--ain.ru';
my $regex = qr/^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}