# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$"
test_str = ("Valid emails:\n"
"user@domain.ru\n"
"na_me.lastname@subdomain.domain.ru\n"
"name-lastname@7.sub-sub-domain.subdomain.domain.ru\n"
"ni+ck'name-name.lastname@d.oma-in-domain.ru\n\n"
"Invalid addresses in the user section:\n"
".user@domain.ru\n"
"user.@domain.ru\n"
"-user@domain.ru\n"
"user-@domain.ru\n"
"us..er@domain.ru\n"
"us--er@domain.ru\n\n"
"Invalid addresses in the domain section:\n"
"user@-domain.ru\n"
"user@.subdomain.domain.ru\n"
"user@subdomain-.domain.ru\n"
"user@subdomain..domain.ru\n"
"user@domain.-domain.ru\n"
"user@dom--ain.ru")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.